Austin Group Defect Tracker

Aardvark Mark III


Viewing Issue Simple Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Type Date Submitted Last Update
0001184 [1003.1(2016)/Issue7+TC2] System Interfaces Objection Omission 2018-01-31 16:49 2019-02-28 16:36
Reporter dennisw View Status public  
Assigned To
Priority normal Resolution Duplicate  
Status Closed  
Name Dennis Wölfing
Organization
User Reference
Section strftime
Page Number 2045
Line Number 65551-65557
Interp Status ---
Final Accepted Text
Summary 0001184: strftime %C padding character unspecified
Description The specification for the %C specifier says that when no minimum field width is specified, at least two characters will be placed. However it does not mention which character is used to pad the result when the year divided by 100 has only one digit, so the padding character is unspecified.

The C standard contains the wording
%C is replaced by the year divided by 100 and truncated to an integer, as a decimal number (00−99). [tm_year]

which makes clear that the number must be padded by '0'.
Desired Action On page 2045 line 65553-65555 section strftime, change:
If a minimum field width is not specified, the number of characters placed into the
array pointed to by s will be the number of digits in the year divided by 100 or two,
whichever is greater.

to:
If a minimum field width is not specified, the number of characters placed into the
array pointed to by s will be the number of digits in the year divided by 100 or two,
whichever is greater, and '0' shall be used as the padding character.
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0000472Interpretation Requiredajosey 1003.1(2008)/Issue 7 strftime %C does not account for sign character 
related to 0000466Resolvedajosey 1003.1(2008)/Issue 7 date +%C problem 

-  Notes
(0003915)
geoffclare (manager)
2018-02-01 09:19

In addition to the desired action, we should also change page 2044 line 65521 from:

The default padding character is unspecified.

to:

The default padding character is unspecified, unless otherwise stated for a particular conversion specifier.
(0004262)
geoffclare (manager)
2019-02-21 17:24

On page 2044 line 65521 section strftime, change:
The default padding character is unspecified.
to:
The default padding character is unspecified, unless otherwise stated for a particular conversion specifier.

On page 2045 line 65553-65555 section strftime, change:
If a minimum field width is not specified, the number of characters placed into the array pointed to by s will be the number of digits in the year divided by 100 or two, whichever is greater. [CX]If a minimum field width is specified, the number of characters placed into the array pointed to by s will be the number of digits in the year divided by 100 or the minimum field width, whichever is greater.[/CX]
to:
If a minimum field width is not specified, the characters placed into the array pointed to by s shall be the value of the year divided by 100, and padded with a leading '0' if needed to reach a minimum of two characters. [CX]If a minimum field width is specified, the number of characters placed into the array pointed to by s shall be the number of digits in the year divided by 100, or the minimum field width, whichever is greater.[/CX]
(0004263)
eblake (manager)
2019-02-21 17:31

The edits made here collide with edits proposed in 0000472

- Issue History
Date Modified Username Field Change
2018-01-31 16:49 dennisw New Issue
2018-01-31 16:49 dennisw Name => Dennis Wölfing
2018-01-31 16:49 dennisw Section => strftime
2018-01-31 16:49 dennisw Page Number => 2045
2018-01-31 16:49 dennisw Line Number => 65551-65557
2018-02-01 09:19 geoffclare Note Added: 0003915
2019-02-21 17:24 geoffclare Note Added: 0004262
2019-02-21 17:24 geoffclare Interp Status => ---
2019-02-21 17:24 geoffclare Final Accepted Text => Note: 0004262
2019-02-21 17:24 geoffclare Status New => Resolved
2019-02-21 17:24 geoffclare Resolution Open => Accepted As Marked
2019-02-21 17:25 geoffclare Tag Attached: tc3-2008
2019-02-21 17:28 eblake Relationship added related to 0000466
2019-02-21 17:29 eblake Relationship added related to 0000472
2019-02-21 17:31 eblake Note Added: 0004263
2019-02-25 16:51 nick Resolution Accepted As Marked => Reopened
2019-02-28 16:32 Don Cragun Final Accepted Text Note: 0004262 =>
2019-02-28 16:32 Don Cragun Status Resolved => Closed
2019-02-28 16:32 Don Cragun Resolution Reopened => Duplicate
2019-02-28 16:36 Don Cragun Relationship replaced duplicate of 0000472
2019-02-28 16:37 geoffclare Tag Detached: tc3-2008


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker