Austin Group Defect Tracker

Aardvark Mark III


Viewing Issue Simple Details Jump to Notes ] Issue History ] Print ]
ID Category Severity Type Date Submitted Last Update
0000661 [1003.1(2008)/Issue 7] Base Definitions and Headers Objection Clarification Requested 2013-02-18 16:41 2019-07-15 15:32
Reporter dangole View Status public  
Assigned To ajosey
Priority normal Resolution Duplicate  
Status Closed  
Name Daniel Golle
Organization
User Reference https://bugs.busybox.net/show_bug.cgi?id=5936 [^]
Section 8.3 Other Environment Variables, TZ variable
Page Number pubs.opengroup.org/onlinepubs/007904975/basedefs/xbd_chap08.html
Line Number 718-843
Interp Status ---
Final Accepted Text
Summary 0000661: gramar of TZ variable is insufficient for describing Israel Daylight-saving time
Description The gramar of the TZ variable doesn't allow one to refer to "the Friday before the last Sunday in March" and not at all to "the first Sunday after October 1. If the end of IDT falls on Rosh Hashanah, the Jewish New Year, then IDT will end on the first Monday after October 1". (from https://en.wikipedia.org/wiki/Israel_Summer_Time [^] )

Obviously, it is possible to specify the rules for a specific year by just refering to the exact days. This would be sufficient if there was a method to define rules for more than just the current year.

The IANA timezone database (tzdata, as used by glibc) provides another, more complex, gramar which is sufficient to express the day-light-saving rules.
Desired Action Extend the TZ variable gramar to be as expressive as the IANA tz database

e.g.
std offset dst offset, rule[@year[-endyear][, rule@year[-endyear]][, ...]]
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0001252Resolved 1003.1(2016)/Issue7+TC2 Extend TZ to allow times outside 00-24 range, permanent DST 

-  Notes
(0001465)
dalias (reporter)
2013-02-18 18:29

Is this extended TZ form present in any existing implementations? If not, I think it might be better to follow existing near-universal practice and standardize the zoneinfo format and the use of relative or absolute zoneinfo pathnames in the TZ variable, rather than inventing a new solution (and thus requiring implementations that want to be both conforming and practical to support both this new form and zoneinfo).
(0004402)
eggert (reporter)
2019-06-02 21:41
edited on: 2019-06-02 21:42

Also please see Issue 001252 http://austingroupbugs.net/view.php?id=1252 [^] which proposes a minor extension to the POSIX TZ spec that would handle current daylight-saving rules in Israel.

(0004406)
joerg (reporter)
2019-06-06 14:52

Is the jewish new year date based on the Gregorian calendar or is it based on the jewish moon calendar?
(0004409)
eggert (reporter)
2019-06-07 16:24

[Replying to joerg's comment.] Starting 2013-06-23 the Hebrew calendar is no longer used to determine daylight-saving transitions in the state of Israel, so the original bug report is no longer relevant for current Israeli practice. Current Israeli practice is to begin DST at 02:00 on the Friday before March's last Sunday, and to end DST at 02:00 on October's last Sunday. This can be specified via TZ='IST-2IDT,M3.4.4/26,M10.5.0' if one assumes the extensions proposed in Issue 001252 http://austingroupbugs.net/view.php?id=1252 [^] to the TZ string.
(0004484)
Don Cragun (manager)
2019-07-15 15:30

Fixed by changes made for 0001252.

- Issue History
Date Modified Username Field Change
2013-02-18 16:41 dangole New Issue
2013-02-18 16:41 dangole Status New => Under Review
2013-02-18 16:41 dangole Assigned To => ajosey
2013-02-18 16:41 dangole Name => Daniel Golle
2013-02-18 16:41 dangole User Reference => https://bugs.busybox.net/show_bug.cgi?id=5936 [^]
2013-02-18 16:41 dangole Section => 8.3 Other Environment Variables, TZ variable
2013-02-18 16:41 dangole Page Number => pubs.opengroup.org/onlinepubs/007904975/basedefs/xbd_chap08.html
2013-02-18 16:42 dangole Line Number => 718-843
2013-02-18 18:29 dalias Note Added: 0001465
2019-06-02 21:41 eggert Note Added: 0004402
2019-06-02 21:42 eggert Note Edited: 0004402
2019-06-02 21:56 Don Cragun Relationship added related to 0001252
2019-06-06 14:52 joerg Note Added: 0004406
2019-06-07 16:24 eggert Note Added: 0004409
2019-07-15 15:30 Don Cragun Interp Status => ---
2019-07-15 15:30 Don Cragun Note Added: 0004484
2019-07-15 15:31 Don Cragun Relationship replaced duplicate of 0001252
2019-07-15 15:32 Don Cragun Status Under Review => Closed
2019-07-15 15:32 Don Cragun Resolution Open => Duplicate


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker